From: Adam Wilson on
I have a recurring problem with my RubyGems install atm.... actually
there are 2 of them, one in /usr/local/lib and the other in /usr/lib

I think it ended up that way after upgrading ruby to 1.8.6.

I have somehow managed to get around problems, but each time I start a
new Rails project, on the server it gives me this error (usuallly on

Rails requires RubyGems >= 1.3.1 (you have 1.3.0). Please `gem update
--system` and try again.

Everytime I try and install it installs in /usr/local/ ... which is
obviously not where Rails is looking.
I have tried a few things, searched here and googled, but nothing I try
seems to work so far..

Any tips much appreciated, need to squash this problem once and for all,
without risking currently running rails sites.

Many thanks
Posted via