From: Joe Perches on
On Sun, 2010-03-28 at 21:36 +0200, Johan Meiring wrote:
> ---
> drivers/staging/line6/midibuf.c | 9 ++++++---
> 1 files changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/line6/midibuf.c b/drivers/staging/line6/midibuf.c
> index ab0a5f3..fb2658d 100644
> --- a/drivers/staging/line6/midibuf.c
> +++ b/drivers/staging/line6/midibuf.c
> @@ -76,7 +76,8 @@ int midibuf_bytes_free(struct MidiBuffer *this)
> return
> midibuf_is_full(this) ?
> 0 :
> - (this->pos_read - this->pos_write + this->size - 1) % this->size + 1;
> + (this->pos_read - this->pos_write + this->size - 1) % \
> + this->size + 1;

It's not necessary to use line continuations like this.

this is an unfortunate variable name, it might be better
to rename it to mb or something.

The "(write - read + size) % size + 1" might be used a
couple of times. Maybe use a macro or function?


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/