From: Bernd Petrovitsch on
Hi!

On Mon, 2010-07-12 at 23:26 +0200, Roel Van Nyen wrote:
[...]
> @@ -178,7 +178,7 @@ vMgrDecodeBeacon(
> break;
> case WLAN_EID_RSN_WPA:
> if (pFrame->pRSNWPA == NULL) {
> - if (WPAb_Is_RSN((PWLAN_IE_RSN_EXT)pItem) == TRUE)
> + if (WPAb_Is_RSN((PWLAN_IE_RSN_EXT)pItem) == true)
> pFrame->pRSNWPA = (PWLAN_IE_RSN_EXT)pItem;
> }
> break;

Am I the only one who thinks that this should better be
---- snip ----
@@ -178,7 +178,7 @@ vMgrDecodeBeacon(
break;
case WLAN_EID_RSN_WPA:
if (pFrame->pRSNWPA == NULL) {
- if (WPAb_Is_RSN((PWLAN_IE_RSN_EXT)pItem) == TRUE)
+ if (WPAb_Is_RSN((PWLAN_IE_RSN_EXT)pItem))
pFrame->pRSNWPA = (PWLAN_IE_RSN_EXT)pItem;
}
break;
---- snip ----
- if only for readability and understandability?

Bernd
--
Bernd Petrovitsch Email : bernd(a)petrovitsch.priv.at
LUGA : http://www.luga.at

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/