From: Anton Vorontsov on
On Tue, Jul 20, 2010 at 01:02:55AM +0100, Ben Hutchings wrote:
> commit 9b9ade6b612e562c4a5bd02ef38cc32e10f3f9ba "ds2782_battery: Add
> support for ds2786 battery gas gauge" introduced an operation named
> get_current. Since get_current() is defined as a macro on some
> architectures this driver no longer compiles on those architectures.
>
> Rename get_current to get_current_now to avoid the macro.
> Rename get_voltage to get_voltage_now for consistency.
>
> Reported-by: Geert Stappers <stappers(a)stappers.nl>
> Signed-off-by: Ben Hutchings <ben(a)decadent.org.uk>
> ---

Thanks for the patch, but I have a similar fix in the
battery-2.6.git tree (for -next):

commit eb9650d6d989f24f21232a055d8fd45f1a9dcf99
Author: Peter Huewe <peterhuewe(a)gmx.de>
Date: Thu May 13 01:54:57 2010 +0200

ds2782_battery: Rename get_current to fix build failure / name conflict

This patch changes the name of get_current function pointer to
get_battery_current to resolve a name conflict with the get_current
macro defined in current.h.

This conflict resulted in a build-failure[1] for the sh4 arch
allyesconfig:

drivers/power/ds2782_battery.c:216:48: error: macro "get_current"
passed 2 arguments, but takes just

This patch fixes the issue. To be consistent the other function pointers
(_voltage,_capacity) were renamed too.

Signed-off-by: Peter Huewe <peterhuewe(a)gmx.de>
Acked-by: Ryan Mallon <ryan(a)bluewatersys.com>
Acked-by: Mike Rapoport <mike(a)compulab.co.il>
Signed-off-by: Anton Vorontsov <cbouatmailru(a)gmail.com>

I'm not pushing this into 2.6.35 as this is not a 2.6.35 regression,
it's there since 2.6.33, and nobody seemed to care for two releases.
So, I'm not considering this as urgent.

Thanks!

--
Anton Vorontsov
email: cbouatmailru(a)gmail.com
irc://irc.freenode.net/bd2
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
From: Ben Hutchings on
On Tue, 2010-07-20 at 11:46 +0400, Anton Vorontsov wrote:
> On Tue, Jul 20, 2010 at 01:02:55AM +0100, Ben Hutchings wrote:
> > commit 9b9ade6b612e562c4a5bd02ef38cc32e10f3f9ba "ds2782_battery: Add
> > support for ds2786 battery gas gauge" introduced an operation named
> > get_current. Since get_current() is defined as a macro on some
> > architectures this driver no longer compiles on those architectures.
> >
> > Rename get_current to get_current_now to avoid the macro.
> > Rename get_voltage to get_voltage_now for consistency.
> >
> > Reported-by: Geert Stappers <stappers(a)stappers.nl>
> > Signed-off-by: Ben Hutchings <ben(a)decadent.org.uk>
> > ---
>
> Thanks for the patch, but I have a similar fix in the
> battery-2.6.git tree (for -next):
[...]

This fix needs to go into 2.6.35.

Ben.

--
Ben Hutchings
Once a job is fouled up, anything done to improve it makes it worse.
From: Anton Vorontsov on
On Tue, Jul 20, 2010 at 10:44:26AM +0100, Ben Hutchings wrote:
> On Tue, 2010-07-20 at 11:46 +0400, Anton Vorontsov wrote:
> > On Tue, Jul 20, 2010 at 01:02:55AM +0100, Ben Hutchings wrote:
> > > commit 9b9ade6b612e562c4a5bd02ef38cc32e10f3f9ba "ds2782_battery: Add
> > > support for ds2786 battery gas gauge" introduced an operation named
> > > get_current. Since get_current() is defined as a macro on some
> > > architectures this driver no longer compiles on those architectures.
> > >
> > > Rename get_current to get_current_now to avoid the macro.
> > > Rename get_voltage to get_voltage_now for consistency.
> > >
> > > Reported-by: Geert Stappers <stappers(a)stappers.nl>
> > > Signed-off-by: Ben Hutchings <ben(a)decadent.org.uk>
> > > ---
> >
> > Thanks for the patch, but I have a similar fix in the
> > battery-2.6.git tree (for -next):
> [...]
>
> This fix needs to go into 2.6.35.

Did you read why I don't push it into 2.6.35? Reread my email,
pay attention to the very bottom.

--
Anton Vorontsov
email: cbouatmailru(a)gmail.com
irc://irc.freenode.net/bd2
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
From: Anton Vorontsov on
On Tue, Jul 20, 2010 at 12:50:19PM +0100, Ben Hutchings wrote:
> On Tue, Jul 20, 2010 at 02:57:12PM +0400, Anton Vorontsov wrote:
> > On Tue, Jul 20, 2010 at 10:44:26AM +0100, Ben Hutchings wrote:
> > > On Tue, 2010-07-20 at 11:46 +0400, Anton Vorontsov wrote:
> > > > On Tue, Jul 20, 2010 at 01:02:55AM +0100, Ben Hutchings wrote:
> > > > > commit 9b9ade6b612e562c4a5bd02ef38cc32e10f3f9ba "ds2782_battery: Add
> > > > > support for ds2786 battery gas gauge" introduced an operation named
> > > > > get_current. Since get_current() is defined as a macro on some
> > > > > architectures this driver no longer compiles on those architectures.
> > > > >
> > > > > Rename get_current to get_current_now to avoid the macro.
> > > > > Rename get_voltage to get_voltage_now for consistency.
> > > > >
> > > > > Reported-by: Geert Stappers <stappers(a)stappers.nl>
> > > > > Signed-off-by: Ben Hutchings <ben(a)decadent.org.uk>
> > > > > ---
> > > >
> > > > Thanks for the patch, but I have a similar fix in the
> > > > battery-2.6.git tree (for -next):
> > > [...]
> > >
> > > This fix needs to go into 2.6.35.
> >
> > Did you read why I don't push it into 2.6.35? Reread my email,
> > pay attention to the very bottom.
>
> It is a 2.6.35 regression; these operations were introduced in 2.6.35-rc1.
> (Hint: use 'git describe --contains' not 'git describe'. Or even
> 'git grep -w get_current v2.6.34:drivers/power/ds2782_battery.c'.)

Oh, I got it.

Will push, thanks!

--
Anton Vorontsov
email: cbouatmailru(a)gmail.com
irc://irc.freenode.net/bd2
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/