From: Robert Richter on
On 16.06.10 12:00:33, Peter Zijlstra wrote:
> Changes perf_disable() into perf_disable_pmu().

I would rather use perf_pmu_disable() as this uses the perf_pmu_XXX
namespace.

-Robert

--
Advanced Micro Devices, Inc.
Operating System Research Center
email: robert.richter(a)amd.com

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
From: Peter Zijlstra on
On Wed, 2010-06-16 at 19:48 +0200, Robert Richter wrote:
> On 16.06.10 12:00:33, Peter Zijlstra wrote:
> > Changes perf_disable() into perf_disable_pmu().
>
> I would rather use perf_pmu_disable() as this uses the perf_pmu_XXX
> namespace.

Sure..

sed -i -e 's/perf_disable_pmu/perf_pmu_disable/g' -e 's/perf_enable_pmu/perf_pmu_enable/g' `quilt series`


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
From: Frederic Weisbecker on
On Wed, Jun 16, 2010 at 06:00:33PM +0200, Peter Zijlstra wrote:
> +static void armpmu_pmu_enable(struct pmu *pmu)
> {
> +static void powerpc_pmu_pmu_disable(struct pmu *pmu)
> {
> +static void fsl_emb_pmu_pmu_disable(struct pmu *pmu)
> {
> +static void sh_pmu_pmu_enable(struct pmu *pmu)
> +{
> +static void sparc_pmu_pmu_enable(struct pmu *pmu)
> {
> +static void x86_pmu_pmu_disable(struct pmu *pmu)
> {


These namings are really bad. Why not just using pmu once
in each names? x86_pmu_enable, etc...

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
From: Peter Zijlstra on
On Fri, 2010-06-18 at 04:14 +0200, Frederic Weisbecker wrote:
> On Wed, Jun 16, 2010 at 06:00:33PM +0200, Peter Zijlstra wrote:
> > +static void armpmu_pmu_enable(struct pmu *pmu)
> > {
> > +static void powerpc_pmu_pmu_disable(struct pmu *pmu)
> > {
> > +static void fsl_emb_pmu_pmu_disable(struct pmu *pmu)
> > {
> > +static void sh_pmu_pmu_enable(struct pmu *pmu)
> > +{
> > +static void sparc_pmu_pmu_enable(struct pmu *pmu)
> > {
> > +static void x86_pmu_pmu_disable(struct pmu *pmu)
> > {
>
>
> These namings are really bad. Why not just using pmu once
> in each names? x86_pmu_enable, etc...

Because some of those were already taken:

static const struct pmu pmu = {
.enable = x86_pmu_enable,
.disable = x86_pmu_disable,

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
From: Frederic Weisbecker on
On Fri, Jun 18, 2010 at 09:11:58AM +0200, Peter Zijlstra wrote:
> On Fri, 2010-06-18 at 04:14 +0200, Frederic Weisbecker wrote:
> > On Wed, Jun 16, 2010 at 06:00:33PM +0200, Peter Zijlstra wrote:
> > > +static void armpmu_pmu_enable(struct pmu *pmu)
> > > {
> > > +static void powerpc_pmu_pmu_disable(struct pmu *pmu)
> > > {
> > > +static void fsl_emb_pmu_pmu_disable(struct pmu *pmu)
> > > {
> > > +static void sh_pmu_pmu_enable(struct pmu *pmu)
> > > +{
> > > +static void sparc_pmu_pmu_enable(struct pmu *pmu)
> > > {
> > > +static void x86_pmu_pmu_disable(struct pmu *pmu)
> > > {
> >
> >
> > These namings are really bad. Why not just using pmu once
> > in each names? x86_pmu_enable, etc...
>
> Because some of those were already taken:
>
> static const struct pmu pmu = {
> .enable = x86_pmu_enable,
> .disable = x86_pmu_disable,


Then those should be renamed into x86_event_enable or so.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/