From: Américo Wang on
On Sat, Nov 14, 2009 at 05:52:05PM -0800, Joe Perches wrote:
>Seems to be a typo.
>

Well, in this case, proc_dointvec == &proc_dointvec,
both of them are the same function pointer.

But yes, &proc_dointvec looks more readable.

>Signed-off-by: Joe Perches <joe(a)perches.com>

Acked-by: WANG Cong <xiyou.wangcong(a)gmail.com>

>
>diff --git a/kernel/sysctl.c b/kernel/sysctl.c
>index 0d949c5..d0bf4eb 100644
>--- a/kernel/sysctl.c
>+++ b/kernel/sysctl.c
>@@ -1605,7 +1605,7 @@ static struct ctl_table debug_table[] = {
> .data = &show_unhandled_signals,
> .maxlen = sizeof(int),
> .mode = 0644,
>- .proc_handler = proc_dointvec
>+ .proc_handler = &proc_dointvec,
> },
> #endif
> { .ctl_name = 0 }
>
>
>--
>To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
>the body of a message to majordomo(a)vger.kernel.org
>More majordomo info at http://vger.kernel.org/majordomo-info.html
>Please read the FAQ at http://www.tux.org/lkml/

--
Live like a child, think like the god.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/