From: Ingo Molnar on

* Li Zefan <lizf(a)cn.fujitsu.com> wrote:

> ____ftrace_check_##name() is used for compile-time check
> on F_printk() only, so it should be marked as __unused
> instead of __used.
>
> Signed-off-by: Li Zefan <lizf(a)cn.fujitsu.com>
> ---
>
> I'm thinking about introducing __always_unused, comparing
> to __maybe_unused.
>
> ---
> kernel/trace/trace_export.c | 5 +++--
> 1 files changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/kernel/trace/trace_export.c b/kernel/trace/trace_export.c
> index 934d81f..85309fc 100644
> --- a/kernel/trace/trace_export.c
> +++ b/kernel/trace/trace_export.c
> @@ -48,11 +48,12 @@
> struct ____ftrace_##name { \
> tstruct \
> }; \
> -static void __used ____ftrace_check_##name(void) \
> +static void __attribute__((unused)) \
> +____ftrace_check_##name(void) \
> { \
> struct ____ftrace_##name *__entry = NULL; \
> \
> - /* force cmpile-time check on F_printk() */ \
> + /* force compile-time check on F_printk() */ \
> printk(print); \
> }

Hm, open-coding __attribute__()'s is not good.

These tags are somewhat of a mess:

#if __GNUC_MINOR__ >= 3
# define __used __attribute__((__used__))
#else
# define __used __attribute__((__unused__))
#endif

I've Cc:-ed Linus and Andrew, to solicite feedback on __always_unused. I
think we should add it.

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/