From: Ingo Molnar on

* Jiri Slaby <jirislaby(a)gmail.com> wrote:

> Hi,
>
> I broke the threading to not mess up with the long thread.
>
> In this version I got rid of the rlim access_only ugliness.

Thanks Jiri - this series looks very clean already and the helpers make
the various usage sites easier to understand as well.

One (very small) naming suggestion, please rename:

rlim_get_cur()
rlim_get_max()
task_rlim_get_cur()
task_rlim_get_max()

To a more natural sounding scheme like:

rlimit()
rlimit_max()
task_rlimit()
task_rlimit_max()

Reasons:

- 'cur' is a misnomer that came a decade+ ago from an ABI and there's
no need to continue that bad tradition in helper functions. It can
also be confused with 'curr' which we often use for the current task.

- 'rlimit' is general meme, plus there's no need to say it out aloud
that we 'get' it - rlimit() is obvious enough.

Beyond solving these issues it makes it shorter and more logical as
well.

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo(a)vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/