From: Laughing Man on
hello,

Today due to my ISP gave me a new ip address and netmask. I changed
the ip address on the Ethernet 1 interface but it would not even pink
the gateway. I made sure that the default gateway was set correctly
with the ip route 0.0.0.0 0.0.0.0 201.159.177.X command. After
troubleshooting a few hours and being stumped it worked when I used
the command ip route 0.0.0.0 0.0.0.0 Eth1. Why would using the
interface name make a difference?

Eth 1 configuration: (last octet replaced with X)

interface Ethernet1
description Internet
bandwidth 10240
ip address 201.159.177.X 255.255.255.252
ip access-group 10 in
ip access-group 10 out
ip nat outside
ip route-cache flow
duplex auto
!

ip route 0.0.0.0 0.0.0.0 Ethernet1

Any thoughts? :-/

Thanx!
From: Doug McIntyre on
Laughing Man <romantercero(a)gmail.com> writes:
>Today due to my ISP gave me a new ip address and netmask. I changed
>the ip address on the Ethernet 1 interface but it would not even pink
>the gateway. I made sure that the default gateway was set correctly
>with the ip route 0.0.0.0 0.0.0.0 201.159.177.X command. After
>troubleshooting a few hours and being stumped it worked when I used
>the command ip route 0.0.0.0 0.0.0.0 Eth1. Why would using the
>interface name make a difference?

>Eth 1 configuration: (last octet replaced with X)

>interface Ethernet1
> description Internet
> bandwidth 10240
> ip address 201.159.177.X 255.255.255.252
> ip access-group 10 in
> ip access-group 10 out
> ip nat outside
> ip route-cache flow
> duplex auto
>!

>ip route 0.0.0.0 0.0.0.0 Ethernet1

>Any thoughts? :-/


Your "fix" will be causing you problems after your router's ARP table
fills up and falls down.

I'd verify with your ISP that you two have your IP addressing correct,
and your idea of your default route matches what they have setup for real.
Mistakes happen with humans entering numbers.

I'd also make sure that you had old info really cleared out. If you
had two default routes, you might get every other one through. Or your
access-groups are filtering out ICMP echo's, or something else.


From: Thrill5 on

"Laughing Man" <romantercero(a)gmail.com> wrote in message
news:0cc880ee-3258-4821-963a-fc9e1826e758(a)g11g2000yqe.googlegroups.com...
> hello,
>
> Today due to my ISP gave me a new ip address and netmask. I changed
> the ip address on the Ethernet 1 interface but it would not even pink
> the gateway. I made sure that the default gateway was set correctly
> with the ip route 0.0.0.0 0.0.0.0 201.159.177.X command. After
> troubleshooting a few hours and being stumped it worked when I used
> the command ip route 0.0.0.0 0.0.0.0 Eth1. Why would using the
> interface name make a difference?
>
> Eth 1 configuration: (last octet replaced with X)
>
> interface Ethernet1
> description Internet
> bandwidth 10240
> ip address 201.159.177.X 255.255.255.252
> ip access-group 10 in
> ip access-group 10 out
> ip nat outside
> ip route-cache flow
> duplex auto
> !
>
> ip route 0.0.0.0 0.0.0.0 Ethernet1
>
> Any thoughts? :-/
>
> Thanx!

Unless you have a mistake in the info you posted.....

If your default route "0.0.0.0 0.0.0.0 201.159.177.X" is the address of YOUR
router, you want the default to point to ISP's router which is X plus or
minus 1. Pointing the default to yourself won't work.