From: ttripp on
I have three serial ports, each a T1 link, that are showing up/up.
I've bundled the three into a single multilink interface. The
multilink is showing down/down. Debugging ppp authentication doens't
show any problems. "show ppp multilink" shows no active bundles, and
all three serial links are listed as inactive, along with the
multilink.

Looking at each serial port, each is showing "Encapsulation PPP, LCP
Open, multilink closed". I've double-checked each serial ports
multilink group settings, and they match the multilink interfaces
group number.

I can post the config, but it's very basic, with no fancy tricks.
It's a very simple Internet-facing router, w/o any routing protocols,
only a single default route, and no access lists applied anywhere.

I'd appreciate any ideas on this. Thanks.
From: Doug McIntyre on
ttripp <ttripp(a)manh.com> writes:
>I have three serial ports, each a T1 link, that are showing up/up.
>I've bundled the three into a single multilink interface. The
>multilink is showing down/down. Debugging ppp authentication doens't
>show any problems. "show ppp multilink" shows no active bundles, and
>all three serial links are listed as inactive, along with the
>multilink.

>Looking at each serial port, each is showing "Encapsulation PPP, LCP
>Open, multilink closed". I've double-checked each serial ports
>multilink group settings, and they match the multilink interfaces
>group number.

>I can post the config, but it's very basic, with no fancy tricks.
>It's a very simple Internet-facing router, w/o any routing protocols,
>only a single default route, and no access lists applied anywhere.

Yeah, we'd probably need to see the config. It should be real
simple. It doesn't take much to do this sort of setup.
I'm guessing that you don't tag each T1 interface as 'ppp multilink'
to have each PPP link in its PPP startup to start doing multilink negotiation.

This is from a working config.

int Multilink1
ip address ...
ppp multilink
ppp multilink group 1
int Serial 1/0/1:0
encaps ppp
ppp multilink
ppp multilink group 1
int Serial 1/0/2:0
encaps ppp
ppp multilink
ppp multilink group 1
int Serial 1/0/3:0
encaps ppp
ppp multilink
ppp multilink group 1

From: ttripp on
On Oct 7, 1:20 pm, Doug McIntyre <mer...(a)geeks.org> wrote:
> ttripp <ttr...(a)manh.com> writes:
> >I have three serial ports, each a T1 link, that are showing up/up.
> >I've bundled the three into a single multilink interface.  The
> >multilink is showing down/down.  Debugging ppp authentication doens't
> >show any problems.  "show ppp multilink" shows no active bundles, and
> >all three serial links are listed as inactive, along with the
> >multilink.
> >Looking at each serial port, each is showing "Encapsulation PPP, LCP
> >Open, multilink closed".  I've double-checked each serial ports
> >multilink group settings, and they match the multilink interfaces
> >group number.
> >I can post the config, but it's very basic, with no fancy tricks.
> >It's a very simple Internet-facing router, w/o any routing protocols,
> >only a single default route, and no access lists applied anywhere.
>
> Yeah, we'd probably need to see the config. It should be real
> simple. It doesn't take much to do this sort of setup.
> I'm guessing that you don't tag each T1 interface as 'ppp multilink'
> to have each PPP link in its PPP startup to start doing multilink negotiation.
>
> This is from a working config.
>
> int Multilink1
>  ip address ...
>  ppp multilink
>  ppp multilink group 1
> int Serial 1/0/1:0
>  encaps ppp
>  ppp multilink
>  ppp multilink group 1
> int Serial 1/0/2:0
>  encaps ppp
>  ppp multilink
>  ppp multilink group 1
> int Serial 1/0/3:0
>  encaps ppp
>  ppp multilink
>  ppp multilink group 1

The running config:


Current configuration : 4795 bytes
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname HOST
!
boot-start-marker
boot system flash c2800nm-ipbasek9-mz.124-12.bin
boot-end-marker
!
logging buffered 4096 informational
enable secret 0 password
!
no aaa new-model
clock timezone EST -5
clock summer-time EDT recurring
no ip source-route
!
!
ip cef
!
!
no ip domain lookup
!
!
crypto pki trustpoint TP-self-signed-3117410074
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3117410074
revocation-check none
rsakeypair TP-self-signed-3117410074
!
!
crypto pki certificate chain TP-self-signed-3117410074
certificate self-signed 01
(chain deleted)
quit
username admin privilege 15 password 0 password
!
!
!
interface Loopback0
ip address 1.x.x.209 255.255.255.255
!
interface Multilink1
bandwidth 4608
ip address x.x.x.94 255.255.255.252
no cdp enable
ppp multilink
ppp multilink group 1
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ES_LAN$
ip address y.y.y.209 255.255.255.240
no ip proxy-arp
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Serial0/1/0
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Serial0/2/0
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
ip route 0.0.0.0 0.0.0.0 x.x.x.93
!
no ip http server
no ip http secure-server
!
access-list 10 permit NOT IN USE
access-list 10 deny any
access-list 90 permit NTP SERVERS
access-list 90 deny any
snmp-server community public RO 10
snmp-server enable traps tty
!
control-plane
!
banner login ^CC
* ***** **** **** **** ***^C
!
line con 0
password 0 password
login
line aux 0
password 0 password
login
modem InOut
transport input all
stopbits 1
speed 19200
flowcontrol hardware
line vty 0 4
login local
transport input ssh
line vty 5 15
login local
transport input ssh
!
scheduler allocate 20000 1000
ntp clock-period 17179274
ntp source FastEthernet0/0
ntp access-group peer 90
ntp server z.z.z.z
!
end

IP addresses and passwords changed to protect the innocent.
From: ttripp on
On Oct 7, 1:42 pm, ttripp <ttr...(a)manh.com> wrote:
> On Oct 7, 1:20 pm, Doug McIntyre <mer...(a)geeks.org> wrote:
>
>
>
>
>
> > ttripp <ttr...(a)manh.com> writes:
> > >I have three serial ports, each a T1 link, that are showing up/up.
> > >I've bundled the three into a single multilink interface.  The
> > >multilink is showing down/down.  Debugging ppp authentication doens't
> > >show any problems.  "show ppp multilink" shows no active bundles, and
> > >all three serial links are listed as inactive, along with the
> > >multilink.
> > >Looking at each serial port, each is showing "Encapsulation PPP, LCP
> > >Open, multilink closed".  I've double-checked each serial ports
> > >multilink group settings, and they match the multilink interfaces
> > >group number.
> > >I can post the config, but it's very basic, with no fancy tricks.
> > >It's a very simple Internet-facing router, w/o any routing protocols,
> > >only a single default route, and no access lists applied anywhere.
>
> > Yeah, we'd probably need to see the config. It should be real
> > simple. It doesn't take much to do this sort of setup.
> > I'm guessing that you don't tag each T1 interface as 'ppp multilink'
> > to have each PPP link in its PPP startup to start doing multilink negotiation.
>
> > This is from a working config.
>
> > int Multilink1
> >  ip address ...
> >  ppp multilink
> >  ppp multilink group 1
> > int Serial 1/0/1:0
> >  encaps ppp
> >  ppp multilink
> >  ppp multilink group 1
> > int Serial 1/0/2:0
> >  encaps ppp
> >  ppp multilink
> >  ppp multilink group 1
> > int Serial 1/0/3:0
> >  encaps ppp
> >  ppp multilink
> >  ppp multilink group 1
>
> The running config:
>
> Current configuration : 4795 bytes
> !
> version 12.4
> service timestamps debug datetime localtime
> service timestamps log datetime localtime
> service password-encryption
> !
> hostname HOST
> !
> boot-start-marker
> boot system flash c2800nm-ipbasek9-mz.124-12.bin
> boot-end-marker
> !
> logging buffered 4096 informational
> enable secret 0 password
> !
> no aaa new-model
> clock timezone EST -5
> clock summer-time EDT recurring
> no ip source-route
> !
> !
> ip cef
> !
> !
> no ip domain lookup
> !
> !
> crypto pki trustpoint TP-self-signed-3117410074
>  enrollment selfsigned
>  subject-name cn=IOS-Self-Signed-Certificate-3117410074
>  revocation-check none
>  rsakeypair TP-self-signed-3117410074
> !
> !
> crypto pki certificate chain TP-self-signed-3117410074
>  certificate self-signed 01
>   (chain deleted)
>   quit
> username admin privilege 15 password 0 password
> !
> !
> !
> interface Loopback0
>  ip address 1.x.x.209 255.255.255.255
> !
> interface Multilink1
>  bandwidth 4608
>  ip address x.x.x.94 255.255.255.252
>  no cdp enable
>  ppp multilink
>  ppp multilink group 1
> !
> interface FastEthernet0/0
>  description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ES_LAN$
>  ip address y.y.y.209 255.255.255.240
>  no ip proxy-arp
>  duplex auto
>  speed auto
> !
> interface FastEthernet0/1
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface Serial0/0/0
>  no ip address
>  encapsulation ppp
>  no fair-queue
>  ppp multilink
>  ppp multilink group 1
> !
> interface Serial0/1/0
>  no ip address
>  encapsulation ppp
>  no fair-queue
>  ppp multilink
>  ppp multilink group 1
> !
> interface Serial0/2/0
>  no ip address
>  encapsulation ppp
>  no fair-queue
>  ppp multilink
>  ppp multilink group 1
> !
> ip route 0.0.0.0 0.0.0.0 x.x.x.93
> !
> no ip http server
> no ip http secure-server
> !
> access-list 10 permit NOT IN USE
> access-list 10 deny   any
> access-list 90 permit NTP SERVERS
> access-list 90 deny   any
> snmp-server community public RO 10
> snmp-server enable traps tty
> !
> control-plane
> !
> banner login ^CC
>             *         ***** **** **** **** ***^C
> !
> line con 0
>  password 0 password
>  login
> line aux 0
>  password 0 password
>  login
>  modem InOut
>  transport input all
>  stopbits 1
>  speed 19200
>  flowcontrol hardware
> line vty 0 4
>  login local
>  transport input ssh
> line vty 5 15
>  login local
>  transport input ssh
> !
> scheduler allocate 20000 1000
> ntp clock-period 17179274
> ntp source FastEthernet0/0
> ntp access-group peer 90
> ntp server z.z.z.z
> !
> end
>
> IP addresses and passwords changed to protect the innocent.- Hide quoted text -
>
> - Show quoted text -

Additionally, here's the output of "show int"

FastEthernet0/0 is up, line protocol is up
Hardware is MV96340 Ethernet, address is 0000.0000.0000 (bia
0000.0000.0000) <-- yes, that's fake
Description: $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ES_LAN$
Internet address is x.x.x.209/28
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:06, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
15 packets input, 2504 bytes
Received 15 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
38 packets output, 4369 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
FastEthernet0/1 is administratively down, line protocol is down
Hardware is MV96340 Ethernet, address is 0000.0000.0000 (bia
0000.0000.0000)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto-duplex, Auto Speed, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Serial0/0/0 is up, line protocol is up
Hardware is GT96K with integrated T1 CSU/DSU
MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open, multilink Closed
Listen: CDPCP, loopback not set
Keepalive set (10 sec)
Last input 00:04:14, output 00:00:07, output hang never
Last clearing of "show interface" counters 00:04:23
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
55 packets input, 884 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
55 packets output, 884 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

Serial0/1/0 is up, line protocol is up
Hardware is GT96K with integrated T1 CSU/DSU
MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open, multilink Closed
Listen: CDPCP, loopback not set
Keepalive set (10 sec)
Last input 00:04:13, output 00:00:06, output hang never
Last clearing of "show interface" counters 00:04:24
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
54 packets input, 868 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
54 packets output, 868 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

Serial0/2/0 is up, line protocol is up
Hardware is GT96K with integrated T1 CSU/DSU
MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open, multilink Closed
Listen: CDPCP, loopback not set
Keepalive set (10 sec)
Last input 00:04:12, output 00:00:05, output hang never
Last clearing of "show interface" counters 00:04:26
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
54 packets input, 868 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
54 packets output, 868 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

Multilink1 is down, line protocol is down
Hardware is multilink group interface
Internet address is y.y.y.94/30
MTU 1500 bytes, BW 4608 Kbit, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Closed, multilink Closed, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 2 seconds on reset
Last input never, output never, output hang never
Last clearing of "show interface" counters 00:04:28
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is z.z.z.209/32
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
From: Artie Lange on
ttripp wrote:

> Multilink1 is down, line protocol is down
> Hardware is multilink group interface
> Internet address is y.y.y.94/30
> MTU 1500 bytes, BW 4608 Kbit, DLY 100000 usec,
> reliability 255/255, txload 1/255, rxload 1/255
> Encapsulation PPP, LCP Closed, multilink Closed, loopback not set
> Keepalive set (10 sec)
> DTR is pulsed for 2 seconds on reset
> Last input never, output never, output hang never
> Last clearing of "show interface" counters 00:04:28
> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
> 0
> Queueing strategy: fifo
> Output queue: 0/40 (size/max)
> 5 minute input rate 0 bits/sec, 0 packets/sec
> 5 minute output rate 0 bits/sec, 0 packets/sec
> 0 packets input, 0 bytes, 0 no buffer
> Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
> 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
> 0 packets output, 0 bytes, 0 underruns
> 0 output errors, 0 collisions, 1 interface resets
> 0 output buffer failures, 0 output buffers swapped out
> 0 carrier transitions


conf t
int multilink1
no shutdown

just a guess?