oom: kill useless debug print
On Tue, 8 Jun 2010, KOSAKI Motohiro wrote: Now, all of oom developers usually are using sysctl_oom_dump_tasks. Redundunt useless debug print can be removed. This is already removed with my heuristic rewrite as you well know, why are you constantly trying to get in the way of that work? -- To unsubscr... 8 Jun 2010 16:02
oom: rename badness() to oom_badness()
On Tue, 8 Jun 2010, KOSAKI Motohiro wrote: badness() is wrong name because it's too generic name. rename it. This is already renamed in my heuristic rewrite which we all agree, in principle, is needed. I'm really confused that you're trying to take little bits and pieces of my work like this, us... 16 Jun 2010 22:08
oom: filter tasks not sharing the same cpuset
On Tue, 8 Jun 2010, KOSAKI Motohiro wrote: From: David Rientjes <rientjes(a)google.com> Tasks that do not share the same set of allowed nodes with the task that triggered the oom should not be considered as candidates for oom kill. You're not a maintainer, as I obviously have to point out to you oft... 8 Jun 2010 16:01
oom: use send_sig() instead force_sig()
On 06/08, KOSAKI Motohiro wrote: Oleg pointed out oom_kill.c has force_sig() abuse. force_sig() mean ignore signal mask. but SIGKILL itself is not maskable. Yes. And we have other reasons to avoid force_sig(). It should be used only for synchronous signals. But, @@ -399,7 +399,7 @@ static int __oom... 13 Jun 2010 08:17
oom: give current access to memory reserves if it has been killed
On Tue, 8 Jun 2010, KOSAKI Motohiro wrote: diff --git a/mm/oom_kill.c b/mm/oom_kill.c index 67b5fa5..ad85e1b 100644 --- a/mm/oom_kill.c +++ b/mm/oom_kill.c @@ -638,6 +638,16 @@ void out_of_memory(struct zonelist *zonelist, gfp_t gfp_mask, } /* + * If current has a p... 8 Jun 2010 14:52
[STAGING] Spectra Flash Translation Layer
Greg, please pull from git://git.infradead.org/users/dwmw2/spectra-2.6.git This was previously known as the 'Moorestown NAND flash driver'. In fact, we have a proper MTD driver for that hardware now, and the only part we want is the FTL -- the pseudo-filesystem which pretends to be a disk drive. It's a sil... 8 Jun 2010 14:52
Perf improvements for .36 (perf/core)
* Arnaldo Carvalho de Melo <acme(a)infradead.org> wrote: From: Arnaldo Carvalho de Melo <acme(a)redhat.com> Hi Ingo, Please pull from: git://git.kernel.org/pub/scm/linux/kernel/git/acme/linux-2.6 perf/core I'll keep perf/urgent for .35 stuff, perf/core now has only things for ... 8 Jun 2010 14:52
[PATCH 09/10] NFS: Extend NFS xattr handlers to accept the security namespace
The existing NFSv4 xattr handlers do not accept xattr calls to the security namespace. This patch extends these handlers to accept xattrs from the security namespace in addition to the default NFSv4 ACL namespace. Signed-off-by: Matthew N. Dodd <Matthew.Dodd(a)sparta.com> Signed-off-by: David P. Quigley <dpquigl(a)ty... 8 Jun 2010 14:52
[PATCH 06/10] NFSv4: Add label recommended attribute and NFSv4 flags
This patch adds a new recommended attribute named label into the NFSv4 file attribute structure. It also adds several new flags to allow the NFS client and server to determine if this attribute is supported and if it is being sent over the wire. Signed-off-by: Matthew N. Dodd <Matthew.Dodd(a)sparta.com> Signed-off... 8 Jun 2010 14:52
Labeled-NFS: Security Label support in NFSv4
It has been quite a while since the last time we submitted a patch set to the mailing list for review. I met with Trond at the last IETF meeting and he suggested that we resubmit the patches for review since the IETF process has moved along since the last posting. When reviewing the code please be critical of it. I... 8 Jun 2010 19:30